Tutrix.dedeine Community für wpForoinoffizieller deutscher wpForo Support

Teilen:
Benachrichtigungen
Alles löschen

V 1: Theme | Design anpassen [Gelöst] Weisses Texteingabefeld für Beitragstext dunkel einfärben

18 Beiträge
2 Benutzer
1 Likes
728 Ansichten
radarin
@radarin
Aktives Mitglied Mitglied
Themen: 4
Beiträge: 29
Punkte: 38
Thema gestartet
 

Hallo zusammen

Ich hab mich auf meiner Seite ebenfalls für wpForo entschieden, da es sich sehr gut in meine Seite integrieren lässt. Ich habe mich für das dunkle Theme entschieden und schon ein paar kleine Darstellungsfehler behoben. Ausserdem hab ich mittles AddOn für die weitere Entwicklung gespendet.

Was mich aber wirklich stört, sind die schneeweissen Textfelder für den Beitragstext. Die blenden Nachts bei der Eingabe ganz übel. Mit folgendem CSS spreche ich die Felder an:

#wpforo #wpforo-wrap.wpf-dark textarea { 
	background-color: blue !important;
	color: red !important;
	z-index: 10000000 !important;
}

Ich habe hier vorerst mal auffällige Farben zum Testen verwendet. Wenn ich die Seite neu lade, wird das Feld kurz blau, aber dann sofort wieder weiss, als lege sich da was drüber. Da hilft leider auch der z-index nicht. Sehen kann man das auf forum.darin.ch, leider aber nur wenn man eingeloggt ist.

Gruß René

 
Beitrag veröffentlicht am : 03.06.2022 19:56
Profil-Infos von radarin
Registriert seit: 03.06.2022 Webseite: https://forum.darin.ch Land: Switzerland Stadt: St.Gallen
Installierte Erweiterungen:   wpForo Addons | Wordpress Addons | Scripte

Anzeige




radarin
@radarin
Aktives Mitglied Mitglied
Themen: 4
Beiträge: 29
Punkte: 38
Thema gestartet
 
.wp-editor-container {
	opacity: 0.5;
}

Dieses DIV ist um die textarea gelegt. Damit wird das Feld um 50% abgedunkelt. Hilft doch schon deutlich. Dunkler aber darf es nicht sein, da die Schrift weiterhin hartnäckig schwarz bleibt.

Allerdings stelle ich gerade fest, klickt man das Textfeld auf die komplette Fenstergrösse, scheint da die Webseite durch. Das ist so dann auch wieder nicht praktikabel.

 
Beitrag veröffentlicht am : 03.06.2022 21:21
Profil-Infos von radarin
Registriert seit: 03.06.2022 Webseite: https://forum.darin.ch Land: Switzerland Stadt: St.Gallen
Installierte Erweiterungen:   wpForo Addons | Wordpress Addons | Scripte

Anzeige




Tutrix
@tutrix
Aktives Mitglied Administrator Support Team
Themen: 77
Beiträge: 482
Punkte: 799
 

Hi @radarin

Eigentlich sollte das Textfeld grau sein, wenn es weiß ist greift wohl die Dark-Formatierung nicht.

Teste mal den CSS Code ohne

.wpf-dark

Ach ja, opacity dunkelt nicht ab sonder gibt dem Element eine Transparenz. Je höher der Wert um so transparenter das Element. Also 0 keine Transparenz 1 volle Transparenz 0.5 somit 50% Transparenz.

Das z-index kannst du auch weglassen, da benötigt man nur wenn ein Element ein anderes überlagern soll, wie z.B. Tooltips, Popups usw.

Ich arbeite mit diesen Programmen sowie Plattformen für Softwareentwickler

Für den Fall, dass du dich bedanken und die Community unterstützen möchtest Buy me a coffee

 
Beitrag veröffentlicht am : 04.06.2022 07:33
Profil-Infos von Tutrix
Registriert seit: 20.01.2020 Webseite: https://www.tutrix.de Land: Germany Stadt: München
Installierte Erweiterungen:   wpForo Addons | Wordpress Addons | Scripte
wpForo Topic Prefix & Tags Manager wpForo Ads Manager wpForo User Custom Fields wpForo Private Messages wpForo Emoticons wpForo Advanced Attachments wpForo Embeds wpForo Syntax Highlighter wpForo User Mentioning WP-UserOnline Wise Chat Pro CleanTalk AntiSpam Code Snippets CM Glossary Tooltip Animate On Scroll Library Toggle Funktion

Anzeige




radarin
@radarin
Aktives Mitglied Mitglied
Themen: 4
Beiträge: 29
Punkte: 38
Thema gestartet
 

.wpf-dark weg lassen macht auch keinen Unterschied. Das mit der Transparenz ist mir schon klar. Da wo nur eine dunkle Fläche dahinter ist, würde es ja funktionieren.

Auffällig ist ja, wenn ich die Seite nachlade blitzt es ganz kurz blau auf, da wo das Feld ist, aber dann ist es wieder weiss. Gerne hätte ich ja das Feld sehr grau und den Text weiss, so wie es dann letztendlich auch auf der Seite dargestellt wird.

Ich hab das mal hier dokumentiert.

 
Beitrag veröffentlicht am : 04.06.2022 12:42
Profil-Infos von radarin
Registriert seit: 03.06.2022 Webseite: https://forum.darin.ch Land: Switzerland Stadt: St.Gallen
Installierte Erweiterungen:   wpForo Addons | Wordpress Addons | Scripte

Anzeige




Tutrix
@tutrix
Aktives Mitglied Administrator Support Team
Themen: 77
Beiträge: 482
Punkte: 799
 

wo fügst du denn den CSS Code ein, da er bei geladenem Forum nirgends zu finden ist

 

Ich arbeite mit diesen Programmen sowie Plattformen für Softwareentwickler

Für den Fall, dass du dich bedanken und die Community unterstützen möchtest Buy me a coffee

 
Beitrag veröffentlicht am : 04.06.2022 12:50
Profil-Infos von Tutrix
Registriert seit: 20.01.2020 Webseite: https://www.tutrix.de Land: Germany Stadt: München
Installierte Erweiterungen:   wpForo Addons | Wordpress Addons | Scripte
wpForo Topic Prefix & Tags Manager wpForo Ads Manager wpForo User Custom Fields wpForo Private Messages wpForo Emoticons wpForo Advanced Attachments wpForo Embeds wpForo Syntax Highlighter wpForo User Mentioning WP-UserOnline Wise Chat Pro CleanTalk AntiSpam Code Snippets CM Glossary Tooltip Animate On Scroll Library Toggle Funktion

Anzeige




radarin
@radarin
Aktives Mitglied Mitglied
Themen: 4
Beiträge: 29
Punkte: 38
Thema gestartet
 

Im Customizer. Im Quelltext ist er im Header drin. Im letzen Post hab ich noch ein Film dazu verlinkt.

Macht auch keinen Unterschied, wenn ich dass CSS in den Einstellungen vom Forum rein schreibe.

 
Beitrag veröffentlicht am : 04.06.2022 12:57
Profil-Infos von radarin
Registriert seit: 03.06.2022 Webseite: https://forum.darin.ch Land: Switzerland Stadt: St.Gallen
Installierte Erweiterungen:   wpForo Addons | Wordpress Addons | Scripte

Anzeige




Tutrix
@tutrix
Aktives Mitglied Administrator Support Team
Themen: 77
Beiträge: 482
Punkte: 799
 
Geschrieben von: @radarin

Im Customizer.

das dürfte dein Problem sein, die CSS vom Forum wird später geladen und überschreibt somit wieder

verwende den CSS-Bereich vom Forum (Einstellungen > Darstellung > Eigener CSS Code)

Ich arbeite mit diesen Programmen sowie Plattformen für Softwareentwickler

Für den Fall, dass du dich bedanken und die Community unterstützen möchtest Buy me a coffee

 
Beitrag veröffentlicht am : 04.06.2022 13:01
Profil-Infos von Tutrix
Registriert seit: 20.01.2020 Webseite: https://www.tutrix.de Land: Germany Stadt: München
Installierte Erweiterungen:   wpForo Addons | Wordpress Addons | Scripte
wpForo Topic Prefix & Tags Manager wpForo Ads Manager wpForo User Custom Fields wpForo Private Messages wpForo Emoticons wpForo Advanced Attachments wpForo Embeds wpForo Syntax Highlighter wpForo User Mentioning WP-UserOnline Wise Chat Pro CleanTalk AntiSpam Code Snippets CM Glossary Tooltip Animate On Scroll Library Toggle Funktion

Anzeige




radarin
@radarin
Aktives Mitglied Mitglied
Themen: 4
Beiträge: 29
Punkte: 38
Thema gestartet
 

Macht leider keinen Unterschied.

Warum wird das Feld ganz kurz blau und dann wieder weiss? Die Anweisungen greifen also grundsätzlich. Liegt das am Editor selber? Den zu beeinflussen scheint aber auch nicht vorgesehen.

 
Beitrag veröffentlicht am : 04.06.2022 13:24
Profil-Infos von radarin
Registriert seit: 03.06.2022 Webseite: https://forum.darin.ch Land: Switzerland Stadt: St.Gallen
Installierte Erweiterungen:   wpForo Addons | Wordpress Addons | Scripte

Anzeige




Tutrix
@tutrix
Aktives Mitglied Administrator Support Team
Themen: 77
Beiträge: 482
Punkte: 799
 

nun wie oben geschrieben, bedeutet das kurze Einblenden das die neuen CSS Formatierungen kurz ausgeführt werden und danach von einer später geladenen CSS Formatierung wieder überschrieben werden.

Du kannst ja mal zum Test ein Forum für Gäste freigeben, dann kann ich mir das ansehen

Ich arbeite mit diesen Programmen sowie Plattformen für Softwareentwickler

Für den Fall, dass du dich bedanken und die Community unterstützen möchtest Buy me a coffee

 
Beitrag veröffentlicht am : 04.06.2022 13:29
Profil-Infos von Tutrix
Registriert seit: 20.01.2020 Webseite: https://www.tutrix.de Land: Germany Stadt: München
Installierte Erweiterungen:   wpForo Addons | Wordpress Addons | Scripte
wpForo Topic Prefix & Tags Manager wpForo Ads Manager wpForo User Custom Fields wpForo Private Messages wpForo Emoticons wpForo Advanced Attachments wpForo Embeds wpForo Syntax Highlighter wpForo User Mentioning WP-UserOnline Wise Chat Pro CleanTalk AntiSpam Code Snippets CM Glossary Tooltip Animate On Scroll Library Toggle Funktion

Anzeige




radarin
@radarin
Aktives Mitglied Mitglied
Themen: 4
Beiträge: 29
Punkte: 38
Thema gestartet
 

Das CSS das ich in den Forumseinstellungen eingebe erscheint nicht im Quellcode.

 
Beitrag veröffentlicht am : 04.06.2022 13:33
Profil-Infos von radarin
Registriert seit: 03.06.2022 Webseite: https://forum.darin.ch Land: Switzerland Stadt: St.Gallen
Installierte Erweiterungen:   wpForo Addons | Wordpress Addons | Scripte

Anzeige




Seite 1 / 2
Teilen:
wpForo theme made with love a lot of time and coffee by Tutrix